Index of /Pinebook64/NetBSD/CDE/
Name | Last Modified | Size | Type |
../ | | - | Directory |
README.txt | 2021-Jun-12 19:30:51 | 4.1K | text/plain; charset=utf-8 |
ast.tar.gz | 2020-May-02 19:20:14 | 46.8M | application/x-gtar-compressed |
cde-2.3.2.tar.gz | 2020-Jan-14 23:57:09 | 54.9M | application/x-gtar-compressed |
dt-2.3.2.tar.gz | 2020-May-02 19:01:59 | 20.8M | application/x-gtar-compressed |
xnedit.tar.gz | 2020-May-02 12:53:51 | 3.0M | application/x-gtar-compressed |
Latest CDE 2.3.2 on NetBSD 9 evbarm Pinebooks
----------------------------------------------
- I have verified the build steps in a vanilla NetBSD 9 arm64 install inside qemu
- And it works on real HW as well (Pinebook/PinebookPro)
- Downloaded a Pinebook image from invisible.ca
- http://www.invisible.ca/arm/netbsd-9/202005010840Z/NetBSD-evbarm-aarch64-202005010840Z-pinebook.img.gz
Installed in KVM accelerated qemu-system-aarch64 for verification process
- Step 1
------
First we need to install a few aarch64 packages that are essential for CDE
We can use the pre-built aarch64 pkgsrc-2019Q4 binary packages on master
ftp.netbsd.org for this
arm64# export PKG_PATH="http://cdn.netbsd.org/pub/pkgsrc/packages"
arm64# export PKG_PATH="$PKG_PATH/NetBSD/aarch64/9.0_2019Q4/All"
arm64# export PATH PKG_PATH
arm64# pkg_add motif
arm64# pkg_add gmake
arm64# pkg_add freetype2
arm64# pkg_add font-adobe-75dpi
arm64# pkg_add font-adobe-100dpi
amr64# pkg_add fontconfig
arm64# pkg_add wget
arm64# pkg_add meson
- Step 2
-------
- Lets create a working directory for CDE
arm64# mkdir $HOME/CDE
arm64# cd $HOME/CDE
- We will first need to download and install ast (korn shell)
- There were numerous issues in the past with the AST kornshell
- on NetBSD, so I have tested my own way of getting in onto
- evbarm
- Original sources were git cloned on December 2019 from
- https://github.com/att/ast
- But the code kept chaning a lot so I have decided to keep my working
- version below which you can use
arm64# wget http://45.76.81.249/Pinebook64/NetBSD/CDE/ast.tar.gz
arm64# gunzip ast.tar.gz
arm64# tar -xvf ast.tar
arm64# cd ast
arm64# meson --prefix=/usr/pkg build
arm64# ninja -C build
arm64# ninja -C build install
arm64# ln -s /usr/pkg/bin/ksh /usr/pkg/bin/ksh93
arm64# /usr/pkg/bin/ksh93 --version
version sh (AT&T Research) 2020.0.0
- We are ready now for the CDE
- There are 2 options now, either download the complete DT binary set from me
- or build it from source, both methods are described here
- (Im working on a pkgsrc script to put all this together)
- If you do not wish to compile the CDE sources you can download the /usr/dt
- gzipped tarball for NetBSD 9 evbarm I have built
- --------------------------------------------------------------------------
arm64# cd $HOME/CDE
arm64# wget http://45.76.81.249/Pinebook64/NetBSD/CDE/dt-2.3.2.tar.gz
arm64# mv dt-2.3.2.tar.gz /usr
arm64# gunzip /usr/dt-2.3.2.tar.gz
arm64# tar -xvf /usr/dt-2.3.2.tar
- Now make sure you ger rpcbind enabled in /etc/rc.conf
- by adding a following line
rpcbind=YES rpcbind_flags="-l"
- And start rpcbind
arm64# /etc/rc.d/rpcbind start
- Also make sure your hostname is properly set in /etc/hosts (CDE needs this)
::1 arm64 localhost localhost.
127.0.0.1 arm64 localhost localhost.
- Now we can finally start CDE by running the following command under your user
arm64$ startx /usr/dt/bin/Xsession
- And add these to your $HOME Xdefaults
Xdefaults
*saveLines:32000
*scrollBar:True
- If you wish to build CDE from source
- ------------------------------------
(if we build this as root otherwise make sure you get the proper $HOME)
arm64# cd $HOME/CDE
arm64# wget http://45.76.81.249/Pinebook64/NetBSD/CDE/cde-2.3.2.tar.gz
arm64# gunzip cde-2.3.2.tar.gz
arm64# tar -xvf cde-2.3.2.tar.gz
arm64# cd cde-2.3.2
arm64# gmake World.dev
arm64# cd admin/IntegTools/dbTools
arm64# ./installCDE -s $HOME/CDE/cde-2.3.2
arm64# cd $HOME
- Now make sure you ger rpcbind enabled in /etc/rc.conf
- by adding a following line
rpcbind=YES rpcbind_flags="-l"
- And start rpcbind
arm64# /etc/rc.d/rpcbind start
-Also make sure your hostname is properly set in /etc/hosts (CDE needs this)
::1 arm64 localhost localhost.
127.0.0.1 arm64 localhost localhost.
- To start X with CDE run the following command under our user
arm64$ startx /usr/dt/bin/Xsession
- And add these to your $HOME Xdefaults
Xdefaults
*saveLines:32000
*scrollBar:True
- As a bonus you also get the XNEDIT sources/binaries for NetBSD 9 evbarm
http://45.76.81.249/Pinebook64/NetBSD/CDE/xnedit.tar.gz