Index of /Sparc/NetBSD/CDE/
Name | Last Modified | Size | Type |
../ | | - | Directory |
README.txt | 2021-Aug-18 12:59:58 | 4.6K | text/plain; charset=utf-8 |
ast.tar.gz | 2021-Aug-18 07:24:08 | 73.4M | application/x-gtar-compressed |
cde-2.3.2.tar.gz | 2021-Aug-18 07:23:42 | 85.6M | application/x-gtar-compressed |
dt-2.3.2.tar.gz | 2021-Aug-18 07:02:11 | 20.4M | application/x-gtar-compressed |
ksh | 2021-Aug-18 12:58:12 | 4.2M | application/octet-stream |
_ _ _ ______ ___________ _____
| \ | | | | | ___ \/ ___| _ \ / ___|
| \| | ___| |_| |_/ /\ `--.| | | | \ `--. _ __ __ _ _ __ ___
| . ` |/ _ \ __| ___ \ `--. \ | | | `--. \ '_ \ / _` | '__/ __|
| |\ | __/ |_| |_/ //\__/ / |/ / /\__/ / |_) | (_| | | | (__
\_| \_/\___|\__\____/ \____/|___/ \____/| .__/ \__,_|_| \___|
| |
|_|
Latest CDE 2.3.2 on NetBSD 9.2 Sparc (big endian)
----------------------------------------------
- I have verified the build steps in a vanilla NetBSD 9.2 sparc install inside qemu
- It should works on real HW as well
- Step 1
------
First we need to install a few packages that are essential for CDE
We can use the pre-built sparc pkgsrc-2021Q2 binary packages on master
cdn.netbsd.org for this
netbsd-sparc# export PKG_PATH="http://cdn.netbsd.org/pub/pkgsrc/packages"
netbsd-sparc# export PKG_PATH="$PKG_PATH/NetBSD/sparc/9.0_2021Q2/All"
netbsd-sparc# export PATH PKG_PATH
netbsd-sparc# pkg_add motif
netbsd-sparc# pkg_add gmake
netbsd-sparc# pkg_add freetype2
netbsd-sparc# pkg_add font-adobe-75dpi
netbsd-sparc# pkg_add font-adobe-100dpi
netbsd-sparc# pkg_add fontconfig
netbsd-sparc# pkg_add wget
netbsd-sparc# pkg_add meson
- Step 2
-------
- Lets create a working directory for CDE
netbsd-sparc# mkdir $HOME/CDE
netbsd-sparc# cd $HOME/CDE
- We will first need to download and install ast (korn shell)
- There were numerous issues in the past with the AST kornshell
- on NetBSD, so I have tested my own way of getting in onto
- evbarm
- Original sources were git cloned on December 2019 from
- https://github.com/att/ast
- But the code kept chaning a lot so I have decided to keep my working
- version below which you can use
netbsd-sparc# wget http://45.76.81.249/Sparc/NetBSD/CDE/ast.tar.gz
netbsd-sparc# gunzip ast.tar.gz
netbsd-sparc# tar -xvf ast.tar
netbsd-sparc# cd ast
netbsd-sparc# meson --prefix=/usr/pkg build
netbsd-sparc# ninja -C build
netbsd-sparc# ninja -C build install
netbsd-sparc# ln -s /usr/pkg/bin/ksh /usr/pkg/bin/ksh93
netbsd-sparc# /usr/pkg/bin/ksh93 --version
version sh (AT&T Research) 2020.0.0
- If you have build probmlems with ksh you can download the Sparc/NetBSD 9.2 binary from this repo
- We are ready now for the CDE
- There are 2 options now, either download the complete DT binary set from me
- or build it from source, both methods are described here
- If you do not wish to compile the CDE sources you can download the /usr/dt
- gzipped tarball for NetBSD 9.2 sparc I have built
- --------------------------------------------------------------------------
arm64# cd $HOME/CDE
arm64# wget http://45.76.81.249/Sparc/NetBSD/CDE/dt-2.3.2.tar.gz
arm64# mv dt-2.3.2.tar.gz /usr
arm64# gunzip /usr/dt-2.3.2.tar.gz
arm64# tar -xvf /usr/dt-2.3.2.tar
- Now make sure you ger rpcbind enabled in /etc/rc.conf
- by adding a following line
rpcbind=YES rpcbind_flags="-l"
- And start rpcbind
netbsd-sparc# /etc/rc.d/rpcbind start
- Also make sure your hostname is properly set in /etc/hosts (CDE needs this)
::1 netbsd-sparc localhost localhost.
127.0.0.1 netbsd-sparc localhost localhost.
- Now we can finally start CDE by running the following command under your user
netbsd-sparc$ startx /usr/dt/bin/Xsession
- And add these to your $HOME Xdefaults
Xdefaults
*saveLines:32000
*scrollBar:True
- If you wish to build CDE from source
- ------------------------------------
(if we build this as root otherwise make sure you get the proper $HOME)
sparc-netbsd# cd $HOME/CDE
sparc-netbsd# wget http://45.76.81.249/Sparc/NetBSD/CDE/cde-2.3.2.tar.gz
sparc-netbsd# gunzip cde-2.3.2.tar.gz
sparc-netbsd# tar -xvf cde-2.3.2.tar.gz
sparc-netbsd# cd cde-2.3.2
sparc-netbsd# gmake World.dev
sparc-netbsd# cd admin/IntegTools/dbTools
sparc-netbsd# ./installCDE -s $HOME/CDE/cde-2.3.2
sparc-netbsd# cd $HOME
- Now make sure you ger rpcbind enabled in /etc/rc.conf
- by adding a following line
rpcbind=YES rpcbind_flags="-l"
- And start rpcbind
sparc-netbsd# /etc/rc.d/rpcbind start
-Also make sure your hostname is properly set in /etc/hosts (CDE needs this)
::1 sparc-netbsd localhost localhost.
127.0.0.1 sparc-netbsd localhost localhost.
- To start X with CDE run the following command under our user
sparc-netbsd$ startx /usr/dt/bin/Xsession
- And add these to your $HOME Xdefaults
Xdefaults
*saveLines:32000
*scrollBar:True
Enjoy CDE on your NetBSD Sparc machine